MPLS和MPLS VPN

2022-6-17 276 6/17

什么是MPLS

即多协议标签交换,通过在二层报头与三层报头之间插入MPLS报头,通过标签和MPLS转发表转发数据。它是现有路由和交换协议的接口,如IP、ATM、帧中继、资源预留协议(RSVP)、开放最短路径优先(OSPF)等等。

与IP转发的区别

IP转发原理
1.路由器通过路由协议生产路由表
2.路由器收到数据包,根据路由表转发数据。
3.路由器根据IP包头的目的IP地址来转发

IP的逐跳转发,在经过的每一跳处,必须进行路由表的最长匹配查找(可能多次),速度缓慢。
MPLS转发原理
1.路由器通过协议生产MPLS转发表(类似路由表)
2.路由器收到数据包,根据MPLS转发表转发数据。
3.路由器根据MPLS报头的标签来转发

MPLS的标签转发,通过事先分配好的标签,为报文建立了一条标签转发通道(LSP),在通道经过的每一台设备处,只需要进行快速的标签交换即可(一次查找)。对于要使用标签转发的路由,不能做路由聚合。

MPLS报头组成

MPLS和MPLS VPN

通常,MPLS报头有32Bit,其中有:

20Bit用作标签(Label)

3个Bit的EXP, 协议中没有明确,通常用作COS 用作流控,

1个Bit的BoS,用于标识是否是栈底,表明MPLS的标签可以嵌套。 用作标记,最靠近二层报头叫栈顶, 最靠近三层报头的叫栈底。允许多个标签被编码到同一个数据包中,形成标签栈,可以把普通的IPV4报文理解为深度为0的标签栈数据包。

8个Bit的TTL 用于防环。如果标签数据包的出发TTL值为0,那么该数据包在网络中的生命期被认为已经过期了。无论是以标签的形式还是不带标签的形式,该报文都不应该继续被转发。

MPLS术语

标签(Label)
是一个定长的,通常只具有局部意义的标识,这些标签通常位于数据链路层的数据链路层封装头和三层数据包之间,标签通过绑定和FEC形成映射关系。
FEC
Forwarding Equivalence Class,FEC(转发等价类),是在转发过程中以等价的方式处理的一组数据分组,可以通过地址、隧道、COS等来标识创建FEC,目前看到的MPLS中只是一条路由对应一个FEC。通常在一台设备上,对一个FEC分配相同的标签。
LSP
标签交换通道。一个FEC的数据流,在不同的节点被赋予确定的标签,数据转发按照这些标签进行。数据流所走的路径就是LSP。
LSR
Label Switching Router,LSR是MPLS的网络的核心路由器,它提供标签交换和标签分发功能。
LER
Label Switching Edge Router,标签交换边缘路由器,在MPLS的网络边缘,进入到MPLS网络的流量由LER分为不同的FEC,并为这些FEC请求相应的标签。它提供流量分类和标签的映射、标签的移除功能。

MPLS的工作原理

1.生成MPLS转发表(LDP协议和IGP协议的配合)
2.LER 压入标签PUST和弹出标签POP的动作
3.LSR 标签交换SWAP,out标签替换in标签
◇LER:IP报文进入时,查找标签转发表,给IP报文打标签操作(PUSH),IP报文离开时,对标签报文进行弹出操作(POP),按IP路由进行转发。
◇LSR:负责对标签报文进行快速的标签交换操作(SWAP)
LER收到报文操作:
1.先查CEF表(IP路由表)
2.再查找MPLS标签转发表,PUST
LSR收到报文操作:
1.查看MPLS标签转发表
2.离开MPLS域的时候,先查看MPLS表,再查看IP路由表。
※优化机制:倒数第2跳弹出机制,就是让倒数第2跳路由器把标签弹出,发送给倒数第1跳路由器就是一个IP报文,倒数第1跳路由器,收到一个IP报文 直接根据IP路由表来转发。

LDP协议

标签分发协议LDP(Label Distribution Protocol)是 MPLS 体系中的一种主要协议。在 MPLS 网络中,MPLS中两个标签交换路由器(LSR)转发流量的标签必须达成一致,MPLS VPN就是基于LDP协议的隧道。

MPLS VPN

MPLS和MPLS VPN
我们常见到的VPN,如GRE、IPsec等,都属于Overlay VPN,而运营商可以提供Peer-To-Peer的基于高速骨干网络的MPLS VPN,如联通云联网、电信CN2等。

MPLS VPN工作原理

MPLS和MPLS VPN
如图, MPLS VPN网络中存在以下角色:
CE(Custom Edge):直接与服务提供商相连的用户设备,现在一般为资源池出口核心交换机。
PE(Provider Edge Router):指骨干网上的边缘路由器,与CE相连,主要负责VPN业务的接入,现在一般为运营商省市骨干网接入节点设备。
P (Provider Router):指骨干网上的核心路由器,主要完成路由和快速转发功能。由于网络规模不同,网络中可能不存在P路由器。PE路由器也可能同时是P路由器。
overlay vpn一般就建立在CE跟CE之间,在CE与CE之间建立隧道,并直接传递路由信息,路由协议数据总是在客户设备之间交换,服务商对客户网络结构一无所知。典型代表是GRE、IPSec。
peer-to-peer vpn一般是在CE和PE之间交换私网路由信息,然后由PE将这些私网路由在P-Network中传播,这样这些私网路由会自动的传播到其他的PE上。通常CE与PE之间运行的路由协议,与P-Network上运行的路由协议是不同的,即使相同,也要有很好的路由过滤和选择的机制,避免私网路由传播到其他PE。

多租户隔离VRF

即虚拟路由转发,使用VRF技术在同一台PE设备做到不同客户CE设备之间的隔离,在同一台CE上做到不同租户的隔离。每个VRF可以理解为一台虚拟逻辑路由器,通过在一台网络设备上创建多个VRF,来支持多个客户的MPLS VPN接入。

RD和RT

RD为路由标识,如果客户的私网网段重叠,路由信息则需要用增加一个8字节的RD字段作为VPNv4路由前缀。
RT为Route Target,一般用做PE设备与CE设备之间维护路由信息,PE将所接收到的VPNv4路由前缀通告给正确的CE设备。

配置

由于已很久没有从事网络配置维护工作,以下配置为之前的笔记,仅做参考:
MPLS VPN配置步骤

1.在MPLS域配置LDP协议
1) 配置IGP协议保证LDP的transport-address可以通信
2) 配置IP CEF
3) 配置LDP协议

ip cef
mpls ip
mpls label protocol ldp
mpls ldp router-id loopback 0
interface FastEthernet0/1
mpls ip

*Show mpls interface
*Show mpls ldp discovery
*Shshow mpls forwarding-table
*show mpls ldp neighbor

2、 在PE设备创建VRF,配置RD和RT,将直连接口关联到VRF

ip vrf SITE1
rd 1:1
route-target export 100:1
route-target import 200:1
interface FastEthernet0/0
ip vrf forwarding SITE1

*Show run | s vrf
*Show ip route vrf SITE1

3、 配置PE-CE路由协议

4、 配置MP-BGP

router bgp 100
bgp router-id 2.2.2.2
no bgp default ipv4-unicast 关闭自动激活ipv4地址簇
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
address-family vpnv4
neighbor 4.4.4.4 activate
*neighbor 4.4.4.4 send-community extended /--自动生成,无需配置--/

*show ip bgp all summary 查看所有地址族下的BGP邻居
*show ip bgp vpnv4 all summary查看VPNV4地址族下的BGP邻居

5、 重分布(可选)

redistribute ospf 1 vrf SITE1 match internal external 1 external 2
internal 自制系统内部的路由,包括域内和域间 O OIA
external 1 external 2 外部的路由 OE1 OE2

 

MPLS VPN 排错思路:
1、先检查路由

R4#show ip bgp vpnv4 all

2、检查标签

R2#show ip bgp vpnv4 all labels 查看私网标签
R2#show mpls forwarding-table 查看外层标签
R2#show ip cef vrf SITE1 192.168.5.5

注意
如果两边PE设备的domain-id相同,则不同CE学到的路由是OIA的路由
如果两边PE设备的domain-id不同,则不同CE学到的路由是OE的路由
默认情况,OSPF的domain-id是等于进程ID
修改domain-id

R2(config)#router ospf 100 vrf SITE1
R2(config-router)#domain-id 2.2.2.2

- THE END -
Tag:

Tenkms

12月01日00:06

最后修改:2023年12月1日
0

非特殊说明,本博所有文章均为博主原创。

共有 0 条评论